项目与项目自身依赖的npm包均引入了不同版本的公共模块导致打包后体积变大该如何解决?

Lee
  • 1
新手上路,请多包涵

项目中引入了A、B(v0.0.1)模块,但是A模块依赖于B(v0.0.2)模块,最终项目打包上线后发现B模块被重复打包导致最终生成的js文件体积变大,求各位大佬帮忙看一下

|- 项目的依赖
    |- A
    |- B(v0.0.1)
    ...
    
|- 模块A依赖
    |- B(v0.0.2)
    ...
回复
阅读 345
3 个回答

既然是不同的版本,那么不同版本之间部分实现一定有一些差异的,不同地方用到的虽然是同一个包,但版本不同,所以都打进去才是一个合理的处理。当然如果你确定0.0.1和0.0.2中用到的部分是兼容的,那么你直接把项目中的依赖升级到0.0.2就可以了

  1. 项目中的依赖选择与依赖一致的依赖,即你也用 Bv0.0.2
  2. 选择依赖 Bv0.0.1 的 A
  3. 建议模块作者使用更宽泛的依赖标记,比如 ~(小版本一致)甚至 ^(大版本一致)

peerDependencies可以的

你知道吗?

宣传栏