vue启动start报错events.js:292 throw error Unhandled 'error' event

Mrlonely
  • 83

刚到新公司,代码拉下来。两天了启动不了 ,在线求
vue-cli3
npm@6.14.12
node@v14.16.1
vue-cli和node 都重新装过和换过版本 电脑mac
image.png

回复
阅读 415
2 个回答

删除node_modulespackage-lock.json,重新安装依赖。

npm cache clean --force
rm -rf node_modules
rm -rf package-lock.json
npm install

npm install 成功之后再次启动 npm start


已参与了 SegmentFault 思否「问答」打卡,欢迎正在阅读的你也加入。

可以删除依赖后重新下载,node版本也不要太低,mac可以用户nvm来管理node版本.
还有就是建议不要用 cnpm 安装 会有各种诡异的bug 可以通过如下操作解决 npm 下载速度慢的问题

npm install --registry=https://registry.npm.taobao.org
已参与了 SegmentFault 思否「问答」打卡,欢迎正在阅读的你也加入。
你知道吗?

宣传栏