安装了Rax但仍然提示Rax相关依赖库missing

cyaolong
  • 13

Mac OS,安装这个教程来配置开发环境,已解决了权限问题,但是卡在了npm start这一步。
如下图,我已经安装了Rax了,但是执行命令还是提示sh: rax-app: command not found
请问大佬们这个问题根源到底是什么?
image.png

查看npm已安装的包,提示报错代码如下:

➜  demo npm ls
@rax-materials/scaffolds-app-js@0.1.0 /Users/Ken/Documents/devDocs/Rax/demo
├── UNMET DEPENDENCY @iceworks/spec@^1.0.0
├── UNMET DEPENDENCY eslint@^6.8.0
├── UNMET DEPENDENCY prettier@^2.1.2
├── UNMET DEPENDENCY rax-app@^3.0.0
├── UNMET DEPENDENCY rax-document@^0.1.0
├── UNMET DEPENDENCY rax-image@^2.0.0
├── UNMET DEPENDENCY rax-link@^1.0.1
├── UNMET DEPENDENCY rax-text@^2.0.0
├── UNMET DEPENDENCY rax-view@^2.0.0
├── UNMET DEPENDENCY rax@^1.1.0
└── UNMET DEPENDENCY stylelint@^13.7.2

npm ERR! code ELSPROBLEMS
npm ERR! missing: @iceworks/spec@^1.0.0, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: eslint@^6.8.0, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: prettier@^2.1.2, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: rax-app@^3.0.0, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: rax-document@^0.1.0, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: rax-image@^2.0.0, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: rax-link@^1.0.1, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: rax-text@^2.0.0, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: rax-view@^2.0.0, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: rax@^1.1.0, required by @rax-materials/scaffolds-app-js@0.1.0
npm ERR! missing: stylelint@^13.7.2, required by @rax-materials/scaffolds-app-js@0.1.0

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/Ken/.npm/_logs/2021-09-05T10_41_00_698Z-debug.log
回复
阅读 222
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
你知道吗?

宣传栏