为什么国产的前端总是无法在git bash中使用?

淡若清风过
  • 70

从vue-cli到vite,用git bash创建项目时总是无法选择,我这里输入2结果还是第一个

回复
阅读 2.8k
3 个回答

emmm (我先下个尝试尝试。。(试了一下震惊。。。居然没办法上下选择。。。不太理解为什么不支持数字回车。。(一种无法上下选择的替代方案)

可以参考使用增加winpty方式 这样就可以在gitbash中用上下按钮去选择了
winpty npm.cmd init @vitejs/app

参考资料

至于根因 参考了两种脚手架创建的对比 vite和随便找的一个create-react-library 发现的确如题主所言。看其源码能很明显的发现区别。vite的交互提示库采用prompts。而另一个采用的是Inquirer.应该只是prompts没考虑到这个功能(果断给他提个issue

不是输入的,是通过上下选择,然后enter键确认的

宣传栏