如何将前端项目中依赖的依赖正确的进行升级?

古道西风瘦马
  • 354

公司项目中甲方程序扫描出[email protected]版本,并指示说要升级到1.21.1版本。
但是其实我们的前端并没有使用这个库,我看了下是node的一个插件使用了这个库,
我使用了npm update [email protected]进行升级,但是package-lock.json中的版本号
依然是1.6.0。
然后我尝试npm uninstall underscore,再npm install [email protected]
package-lock.json文件中[email protected]的代码块依然存在,只是再原来了的基础上
增加了[email protected]版本的代码块。
请问如何正确的升级指定版本?

回复
阅读 606
1 个回答
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏