composer私有库依赖包如何版本兼容?

自己写了一个composer私有包, 其中依赖了guzzleHttp第三方库,默认安装的是7.x版本, 然后我在其中一个项目中引入这个包可以正常安装,但是在第二个项目中引入的话,使用composer update会报以下错误

overtrue/wechat 4.2.11 requires guzzlehttp/guzzle ^6.2 -> satisfiable by guzzlehttp/guzzle[6.2.0, ..., 6.5.8].
...
...
Conclusion: don't install guzzlehttp/guzzle 7.2.0 (conflict analysis result)

但是如果把私有包的guzzleHttp修改为6.x, 结果第一个项目又不支持。

如何才能保证2个项目都能正常安装?

回复
阅读 764
2 个回答

这种包版本冲突可以去修改自己项目中引入的包的版本 尽量和原来包版本兼容

如果还是不行的话 可以重新fork一个出来 引入fork的包即可

宣传栏