macos monterey brew 怎么安装 php5.6?

brew tap exolnet/homebrew-deprecated 过了
image.png
image.png
提示错误 invalid bottle tag symbol。
应该如何安装php5.6啊?
用了阿里源和官方源都不行。
可以search 出来,但是提示错误。

回复
阅读 1.2k
1 个回答

建议先执行brew update将brew更新到最新,再执行上述操作。
另:deprecated的意思是:已被弃用的。我想安装不上它的原因在于此。

官方查询PHP,并没有发现5.6版本:

image.png

也就是说brew安装并不支持安装5.6版本。


php5.6可以使用docker来轻松安装。

  1. 安装docker
  2. 运行docker
  3. docker pull php:5.6-zts-jessie
  4. `docker run -it -d -v /your/phpapp/path:/home/phpapp php:5.6-zts-jessie /bin/bash
  5. 上述命令将启动一个docker容器,并将/your/phpapp/path挂载到容器的/home/phpapp(可以随意换成自己习惯的)上,此时shell已经是docker容器的了,可以执行php -v查看版本,或是cd /home/phpapp,然后执行php somefile.php.

当然了,如果你需要一个apache的集成环境,则也可以使用docker来安装. https://hub.docker.com/ 上面提供的众多应用,基本上能完全满足我们的环境需求。

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏