webpack编译报错,因为无法识别 ?. 所以需要加载适当的loader来处理此文件类型?

正在配置cesium环境,结果编译后出现了这个错误,有些少见:

 ERROR  Failed to compile with 1 error                                                                                                                                                    上午10:10:57

 error  in ./node_modules/cesium/Source/Scene/Model/MetadataPipelineStage.js

Module parse failed: Unexpected token (86:29)
You may need an appropriate loader to handle this file type.
|   const { shaderBuilder, model } = renderResources;
|   const { structuralMetadata = {}, content } = model;
>   const statistics = content?.tileset.metadataExtension?.statistics;
|
|   const propertyAttributesInfo = getPropertyAttributesInfo(

我记得翻阅了很多对应的You may need an appropriate loader to handle this file type.这类问题解决方法,终于有找到过一个类似的,因为?.无法编译的,但是,他的解决方法是配置vue-loader,我按照他的方法做的话,整个项目都无法编译。而且我看了我的vue.config.js,其实早就配有vue-loader,只是不是他那种配法。

    config.module
      .rule('vue')
      .use('vue-loader')
      .loader('vue-loader')
      .tap(options => {
        options.compilerOptions.preserveWhitespace = true
        return options
      })
      .end()

一样无法解决。
对了,我的cesium是1.98版本的(直接下最新的,没有选择特定的版本)。

求助:这个问题如何解决?

回复
阅读 3.9k
4 个回答
✓ 已被采纳

版本不对 我本来也有这个问题 原来cesium版本是1.100.0 改成1.95.0就好了

新手上路,请多包涵

我来回答一下吧 cesium 版本不对

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏