题目1 : Font Size

时间限制:10000ms
单点时限:1000ms
内存限制:256MB

描述
Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.
Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven's phone screen is limited. Its width is W and height is H. As a result, if the font size of characters is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)
So here's the question, if Steven wants to control the number of pages no more than P, what's the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.
输入
Input may contain multiple test cases.
The first line is an integer TASKS, representing the number of test cases.
For each test case, the first line contains four integers N, P, W and H, as described above.
The second line contains N integers a1, a2, ... aN, indicating the number of characters in each paragraph.

For all test cases,
1 <= N <= 103,
1 <= W, H, ai <= 103,
1 <= P <= 106,
There is always a way to control the number of pages no more than P.
输出
For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.
样例输入
2
1 10 4 3
10
2 10 4 3
10 10
样例输出
3
2

以下是我写的代码:

#include<iostream>
#include<math.h>
#include<iomanip>
using namespace std;

int main(){
    int ta;cin>>ta;
    for(int i=0;i<ta;i++){
        int n,p,w,h;    
        
        cin>>n>>p>>w>>h;
        int *a=new int[n+1];//new
        for(int j=0;j<n;j++){
            cin>>a[j];
        }
        a[n]='\0';
        int s;
        int wh= w>h ? h:w;
        //cout<<wh<<"zuixiaode "<<endl;
        s=wh;//chushihua为最大
        int *b=new int[n+1];//每个段落需要的行数
        while(1){
            int wn=w/s;
            int hn=h/s;
            int B=0;//所需总行数
            for(int j=0;j<n;j++){
                double t=ceil(double(a[j])/double(wn));
                b[j]=(int)t;
                B=B+b[j];
            }
            b[n]='\0';

            double te=ceil(double(B)/double(hn));
            int P=(int)te;//所需总页数
            if(P>p)
                s--;
            else
                break;
        }
        delete []b;
        delete []a;
        cout<<s<<endl;
        

    }
    return 0;
}

peixn
78 声望2 粉丝