[centos]关于libstdc++.so.6这个库与网易云音乐版本不兼容问题

猫哥

1:问题:/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found

网易云音乐,有道字典在CentOS Linux release 7.2.1511 下不能运行的问题
原因:由于开发人员使用的更高版本的gcc,而本机上面使用的gcc和对应的动态链接库版本过低
解决方法:下载高版本的gcc进行编译安装

现象:
./netease-cloud-music 
./netease-cloud-music: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./netease-cloud-music)

查看库支持的版本的命令:
cd /lib64
strings libstdc++.so.6 |grep GLIBCXX

显示结果
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13
GLIBCXX_3.4.14
GLIBCXX_3.4.15
GLIBCXX_3.4.16
GLIBCXX_3.4.17
GLIBCXX_3.4.18
GLIBCXX_3.4.19
GLIBCXX_3.4.20
GLIBCXX_DEBUG_MESSAGE_LENGTH

3:下载高版本的gcc

1:下载链接:http://mirrors.hust.edu.cn/gn...
2:编译,安装过程

解压后进入目前
./contrib/download_prerequisites
./configure --prefix=/usr --enable-languages=c,c++ --disable-multilib
make -j4  #等50分钟左右
sudo make install 

4:处理libstdc++问题

1:进入刚才编译的gcc5.4的如下目录
/home/cherish/gcc-5.4.0/x86_64-unknown-linux-gnu/libstdc++-v3/src/.libs

2:将libstdc++.so.6.0.21 复制到/lib64目录下
sudo cp  libstdc++.so.6.0.21 /lib64

3:将/lib64之前的旧的链接删掉,建立新的软链接
cd /lib64
sudo rm libstdc++.so.6
sudo ln -sv libstdc++.so.6.0.21 libstdc++.so.6

5:安装网易云音乐

1:到网易云音乐官网下载如下安装包:
netease-cloud-music_1.0.0_amd64_ubuntu16.04.deb

2:解压上面安装包,进入目录netease-cloud-music_1.0.0_amd64_ubuntu16.04

3:接着解压data.tar.xz文件,得到usr目录
tar xvf data.tar.xz

4:复制usr目录下所有文件到/usr目录下
sudo cp usr/*  /usr -rf

5:进入/usr/lib/netease-cloud-music/ 目录
cd /usr/lib/netease-cloud-music/
sudo chmod 4775 chrome-sandbox 

6:恭喜你,现在可以运行网易云音乐了,输入如下命令运行程序
netease-cloud-music

7:后面给应用程序添加图标就自己折腾吧

6:最终效果

使用ubuntu版本的网易运音乐在centos上运行非常给力,没有死掉,卡住的问题

图片描述 图片描述
阅读 8.9k

cherishsir
do some research about memory system

热衷于研究各类互联网技术,热爱学习,热爱生活!

297 声望
28 粉丝
0 条评论

热衷于研究各类互联网技术,热爱学习,热爱生活!

297 声望
28 粉丝
宣传栏