centos 6.7 安装 最新版 git

fuyi501

本来打算在 centos 中安装 nodejs,先安装 nvm ,结果报错,安装不了,后来看到是因为 git 的版本问题,yum 源里的 git 版本太老了(1.7.1),所以必须安装新版,现在的新版最新为 2.10.1 (2016年10月11日),其实新版也不用安装最新的,反正 2.8 版本的也能用,我这里就安装最新的。

写在前面

遇到问题的时候,经常需要查 百度或谷歌,有时候一篇文章可能还解决不了问题,就需要看多篇文章,结果发现好多文章都是直接复制粘贴的,也不知道原作者是谁,一点自己的问题都没有,直接抄。看这种文章简直是浪费时间,对这些作者表示很坑,特别反感这种,我觉得写文章除了自己记录之外,也是一种知识分享,经验交流,写博客写文章就应该认认真真,把自己的问题叙述清楚,然后把解决方案讲明白,不要误导别人。

有这样的感受,所以我写文章都是很认真的,都是自己在看过很多文章,思考之后总结出来的,我们可能遇到的问题不同,但多多少少可以给些提示,说不定哪一个细节就是问题的关键所在呢,谢谢~~

下载最新版 git

从 github 上下载最新版的 git 源码

网址 :https://github.com/git/git/

打开网址后,点击 releases ,可以看到目前最新的 git 版本

图片描述

图片描述

从上图看到,最新版是 2.10.1 ,不要下载带有-rc的,因为它代表了一个候选发布版本,使用 wget 下载 v2.10.1 最新版本。

wget https://github.com/git/git/archive/v2.10.1.tar.gz

下载成功后,对其解压

➜  ~ ls
v2.10.1.tar.gz
➜  ~ tar -zvxf v2.10.1.tar.gz 

解压完成后 ,会多出一个 git 文件

➜  ~ ls
git-2.10.1  v2.10.1.tar.gz

安装编译工具 和 依赖包

在编译 git 之前,需要安装 编译工具和一些依赖文件,否则编译的时候会出错

➜  ~ yum groupinstall "Development Tools" #安装 编译工具包

再安装依赖包

➜  ~ yum install zlib-devel perl-ExtUtils-MakeMaker asciidoc xmlto openssl-devel

安装完成后就开始编译 git 源码了

编译 git 源码

进入 git 源码文件目录,执行下面的命令

➜  ~ cd git-2.10.1 
➜  ~ autoconf    #自动配置
➜  ~ ./configure  
➜  ~ make && make install

图片描述
图片描述
图片描述

没有出错,编译成功了。

添加 git 符号链接

安装好的git是在/usr/local/bin/git下面,通过link来进行调用。如果报文件已经存在的错误,可以将原来的 git 删掉。

➜  ~ ls /usr/local/bin
git            gitk              git-shell           git-upload-pack
git-cvsserver  git-receive-pack  git-upload-archive
➜  ~ ln -s /usr/local/bin/git /usr/bin
ln: 创建符号链接 "/usr/bin/git": 文件已存在
➜  ~ rm /usr/bin/git
➜  ~ ln -s /usr/local/bin/git /usr/bin
➜  ~ git --version
git version 2.10.1
➜  ~ 

图片描述

再次 查看 git 的版本就是 2.10.1 了

文中如有纰漏或者有什么问题,可以提出来,谢谢~~

阅读 5.3k

傅毅
逆袭的码农

你觉得痛苦的事情对你往往是有好处的

257 声望
7 粉丝
0 条评论
你知道吗?

你觉得痛苦的事情对你往往是有好处的

257 声望
7 粉丝
宣传栏