一个NoClassDefFoundError的解决过程

Sanchi

内含分析过程,如寻找答案,直接查看解决方式

今天在android studio项目内添加了几个jar包之后突然项目就跑不起来了,直接崩溃。在logcat看日志,报错信息如下:

E/AndroidRuntime: FATAL EXCEPTION: main
Process: com.san.bili, PID: 31934
java.lang.NoClassDefFoundError: io.reactivex.processors.PublishProcessor
  at com.san.library.observe.RxBus.<init>(RxBus.java:17)
  at com.san.library.observe.RxBus.getInstance(RxBus.java:24)
  at com.san.library.observe.MsgMgr.initUiThread(MsgMgr.java:28)
  at com.san.bili.module.logic.application.App.onCreate(App.java:47)
  at android.app.Instrumentation.callApplicationOnCreate(Instrumentation.java:1009)
  at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4613)
  at android.app.ActivityThread.access$1800(ActivityThread.java:139)
  at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1316)
  at android.os.Handler.dispatchMessage(Handler.java:102)
  at android.os.Looper.loop(Looper.java:136)
  at android.app.ActivityThread.main(ActivityThread.java:5314)
  at java.lang.reflect.Method.invokeNative(Native Method)
  at java.lang.reflect.Method.invoke(Method.java:515)
  at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:864)
  at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:680)
  at dalvik.system.NativeStart.main(Native Method)

刚才还跑的好好的代码怎么突然就出了问题,那么进行一些大胆的猜测:

  1. 导包失败(经排查,compile一切正常)

  2. 导入的jar包中同样含有rxJava的库(经过排查,实际上没有)

  3. 代码混淆造成的类读取失败(经排查发现rxJava已经添加过proguard了)

测试混淆的时候还发现另一个奇怪的问题,release包跑得好好的,就debug包会报错。这时候我已经开始怀疑人生了,难道玄学之光照耀我身?忍不住去重新查了一遍api文档,并开始慌了。最后,发现logcat中有如下打印:

D/dalvikvm: Late-enabling CheckJNI
I/dalvikvm: Failed resolving Lio/reactivex/Flowable; interface 9267 'Lorg/reactivestreams/Publisher;'
W/dalvikvm: Link of class 'Lio/reactivex/Flowable;' failed
W/dalvikvm: VFY: unable to find class referenced in signature (Lio/reactivex/Flowable;)
W/dalvikvm: VFY: unable to resolve virtual method 51466: Lio/reactivex/Flowable;.onBackpressureBuffer ()Lio/reactivex/Flowable;
D/dalvikvm: VFY: replacing opcode 0x6e at 0x0019

JNI?我顿时有了一个大胆的想法,难道跟分包有关?我已经添加了multiDexEnabled true,也没有65535提示?再次求助,此时比利王的哲学之光升起,还真是分包的问题。

解决方式

  1. defaultConfig中添加multiDexEnabled = true

  2. 导入分包support库compile 'com.android.support:multidex:1.0.1'

  3. MultiDexApplication替代Application,或者在你application的attachBaseContext()方法中调用MultiDex.install()

再次运行,问题解决。

深入研究

关于android studio分包配置的官方文档,须注意项目配置的minSdkVersion翻到这篇博客的同学们都去重新看一遍啊喂!

阅读 20.8k

share
我也是个菜鸟。希望大家都不会跟我一样走弯路~

0100100100100111011011010010000001110111011010010111010001101000001000000111100101101111011101010...

361 声望
14 粉丝
0 条评论

0100100100100111011011010010000001110111011010010111010001101000001000000111100101101111011101010...

361 声望
14 粉丝
文章目录
宣传栏