题目:U - Number Sequence
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A f(n - 1) + B f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n);
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
样例:
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
思路:对于这样的斐波那契数列的题目的处理,本来应该是循环依次找到,但这个样子最后会超时。所以这个时候就应该想到是有规律在里面。即不能全部循环到对应的n。
新技巧:对应这样斐波那契数列的问题,一层循环都超时的情况,则就是有规律可寻,所以这时候则要写出来,然后对应看能否找到规律。这里即每48个是一层循环;
代码:
#include<stdio.h>
int main()
{
int A,B,n,i,a[48];
while(scanf("%d%d%d",&A,&B,&n)!=EOF)
{
if(A==0&&B==0&&n==0)
break;
a[0]=1;a[1]=1;
for(i=2;i<48;i++)
{
a[i]=(A*a[i-1]+B*a[i-2])%7;
}
printf("%d\n",a[(n-1)%48]);
}
return 0;
}
**粗体** _斜体_ [链接](http://example.com) `代码` - 列表 > 引用
。你还可以使用@
来通知其他用户。