Stones

Time Limit: 5000/3000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3500 Accepted Submission(s): 2270

Problem Description

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input

In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output

Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12


http://acm.hdu.edu.cn/showpro...

Accepted Code

// Author : Weihao Long
// Created : 2018/03/17

#include <bits/stdc++.h>

using namespace std;

struct node {
    int location;
    int distance;
    friend bool operator<(node a, node b) {
        if (a.location == b.location)
            return a.distance > b.distance;
        return a.location > b.location;
    }
}temp;

int main() {
    int t;
    cin >> t;
    while (t--) {
        int ans = 0;
        int n;
        cin >> n;
        priority_queue<node> pq;
        while (n--) {
            cin >> temp.location >> temp.distance;
            pq.push(temp);
        }
        bool flag = true;
        while (!pq.empty()) {
            temp = pq.top();
            if (flag) {
                temp.location += temp.distance;
                ans = temp.location;
                pq.push(temp);
            }
            flag = flag == true ? false : true;
            pq.pop();
        }
        cout << ans << endl;
    }
    return 0;
}

Notes

题意:
扔石头,每奇数次遇见石头就捡起来扔,偶数次就忽略,问最后一个石头离起点的距离。

算法:
优先队列。


龙威昊
4 声望5 粉丝