Ubuntu16.04安装Docker

Developer

一、准备

Docker 要求 Ubuntu 系统的内核版本高于 3.10,通过下面的命令查看内核版本:

$ uname -r

二、安装

1. 卸载旧版本

Docker 的旧版本名称为:docker 、 docker-engine 或者 docekr-io。
如果安装过旧版本的需要先卸载:

$ sudo apt-get remove docker docker-engine docker.io

2. 安装最新版本的 Docker

最新版本的 Docker 分两个版本,docker-ce(Community Edition)和docker-ee(Enterprise Edition)。CE版本是免费的,如果我们学习或者一般应用,CE足够。我们安装社区版:

由于docker安装需要使用https,所以需要使 apt 支持 https 的拉取方式。

2.1 安装 https 相关的软件包

$ sudo apt-get update # 先更新一下软件源库信息

$ sudo apt-get install \
    apt-transport-https \
    ca-certificates \
    curl \
    software-properties-common

2.2 设置apt仓库地址

鉴于国内网络问题,强烈建议使用国内地址

  1. 添加 Docker 官方apt仓库(使用国外源)
    执行该命令时,如遇到长时间没有响应说明网络连接不到docker网站,需要使用国内的

    # 添加 Docker 官方的 GPG 密钥(为了确认所下载软件包的合法性,需要添加软件源的 GPG 密钥)
    $ curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
    
    # 设置稳定版本的apt仓库地址
    $ sudo add-apt-repository \
       "deb [arch=amd64] https://download.docker.com/linux/ubuntu \
       $(lsb_release -cs) \
       stable"
  2. 添加 阿里云 的apt仓库(使用国内源)

    $ curl -fsSL https://mirrors.aliyun.com/docker-ce/linux/ubuntu/gpg | sudo apt-key add -
    
    $ sudo add-apt-repository \
         "deb [arch=amd64] https://mirrors.aliyun.com/docker-ce/linux/ubuntu \
         $(lsb_release -cs) \
         stable"

2.3 安装 Docker 软件

$ sudo apt-get update

$ sudo apt-get install docker-ce # 安装最新版的docker

如果要安装指定版本的docker,则使用下面的命令:

$ apt-cache policy docker-ce # 查看可供安装的所有docker版本
$ sudo apt-get install docker-ce=18.03.0~ce-0~ubuntu # 安装指定版本的docker
``
### 2.4 检查docker是否安装成功

$ docker --version # 查看安装的docker版本

阅读 16.8k

全栈开发之路
全栈,从一个小渣渣开始做起 = - = 编程语言就是一个工具,学会如何用好它来解决实际问题是关键。 前端...

只要还在学习,人生就有无限的希望...

1.3k 声望
109 粉丝
0 条评论

只要还在学习,人生就有无限的希望...

1.3k 声望
109 粉丝
文章目录
宣传栏