Appium超详细环境搭建for-Mac

兜兜转转试用了一圈自动化框架后,回归到appium,与一年之前相比,appium有了很大的改变:
1、iOS 9 之前一直以 instruments 下的 UIAutomation为驱动底层技术(弊端由于 instruments 的限制,单台 mac 只能对应单台设备);
2、iOS 9.3 时代推出 XCUITest 工具,用以替代 UIAutomation;
3、iOS 10 时代苹果直接废弃了 UIAutomation、Facebook 推出 WebDriverAgent(实现的 server 能够支持单台 mac 对应多个设备);4、Appium 在iOS 9.3 后全面采用 WebDriverAgent 的方案。

首先,我们要知道环境搭建所需工具:

Screen Shot 2018-09-25 at 2.43.03 PM.png

其次,重中之重:版本很重要,我的是:xcode9.3 + node10.11.0 + appium1.7.0,如果根据以下配置仍然不能成功运行,那么99%是版本的问题

下面开始逐个安装
1、安装node
brew install node
通过这种方法安装的node是最新版本,因为我本地需要有node 8.1.1版本,所以使用nvm进行安装
备注:nvm的安装和使用

2、下载Xcode 和 Command Line Tools:需要有个AppleID,并根据自己电脑OS版本下载所需版本
下载地址

E8DEB1470C15778F79478BC10CDAF563.png

下载后直接安装即可,注意Xcode保持在application文件夹下只有一个唯一版本

3、下载安装JDK
oracle官网下载地址
971CDCD491D2B3FF0E8D1951CE8B8269.png

下载完成后直接安装即可

4、安装Android SDK
很多资料都推荐使用brew安装,但是实践后发现SDK文件为空,所以使用Android studio来安装
下载Android studio

具体安装步骤见此文档

如果打开Android studio报错,直接cancel到下一步即可;若使用default方式安装,也可以在configuration里重新下载相关tools
Screen Shot 2018-09-25 at 4.35.04 PM.png

B3391D6D-9C5D-4102-8259-CA74090799DA.png

5、安装appium最新版本
github release版本下载
A432334072A63A419043296A58451F57.png

这里不使用npm下载方式是因为下载过程较长,且容易报错

6、安装appium-doctor
npm install -g appium-doctor

7、配置Android环境变量
在 ~/.bash_profile文件中添加path

export ANDROID_HOME=~/Library/Android/sdk/
export JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.8.0_171.jdk/Contents/Home #jdk安装路径   
export PATH=~/bin:$PATH:/usr/local/bin:$ANDROID_HOME/platform-tools/:$JAVA_HOME/bin
export CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar

在appium的configurations里设置:
5F0F08843C1F22CA122105FF0E21065C.png

8、安装其他依赖
brew install libimobiledevice --HEAD
npm install -g ios-deploy
brew install carthage

libimobiledevice / ideviceinstaller 库:相当于 android 的 adb,是 Appium 底层用到的工具之一,用于获取 iOS 设备信息
ios-deploy:查看设备应用
carthage:类似于 java 的 maven,项目依赖管理,主要是 WebDriverAgent 使用

9、配置WebDriverAgent
(1)首先进入WebDriverAgent所在文件目录下:
/Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent
(2)根目录下执行:
./Scripts/bootstrap.sh
(3)打开WebDriverAgent.xcodeproj工程文件
(4)添加自己的account:Xcode -> Preferences -> account -> 左下角 +
57C1E9FC323D02D56D05D7D53F02E448.png
(5)更改bundle id:这里的bundle id就相当于一个App的唯一识别号,更改的规则随意,只要确认不会与有重复即可;所有的targets都需要修改
59411E04545F3BEBA5FF9534CDE6492C.png

2555C54B7D27230343BB8B9B1D7E11E5.png

10、验证是否环境已经安装成功了
(1)终端输入:appium-doctor
如果环境都已配置好,应该是文章最开始图片中的结果
(2)运行WebDriverAgentRunner
Screen Shot 2018-09-25 at 6.25.52 PM.png
按照图中
1:选择scheme为WebDriverAgentRunner -> 2:选择运行设备,模拟器和真机都可以 -> 3:选择要构建的方式 ->4:选择Test方式
的步骤验证是否能成功运行WebDriverAgentRunner

如果真机运行后弹出需要在设置中信任证书,

Verify the Developer App certificate for your account is trusted on your device. Open Settings on iPhone and navigate to General -> Device Management, then select your Developer App certificate to trust it.

按照步骤操作后,重新运行就可以了
Screen Shot 2018-09-18 at 3.03.24 PM.png

成功运行结果图:
A5DBAF06D2724DB07A7F771A8114B6E7.png

11、遇到的问题总结
1、appium版本不支持xcode版本(需要调用XCUITest),重新下载可匹配的Xcode版本
Xcode9.3 + Appium1.6.4时,运行WebDriverAgentRunner报错

Early unexpected exit, operation never finished bootstrapping - no restart will be attempted

0F6AFF47CDBA9190551885A5AC0423B2.png

解决方法:更新Appium版本到1.7.0

2、appium无法调起webdriverrunner(webdriveragent更新),查看是否因为webdriveragent证书签名、依赖framework、serverURL抛出错误信息
安装依赖framework时报错:

Falling back to building from the source
A shell task (/usr/bin/xcrun xcodebuild -project /Applications/Appium.app/Contents/Resources/app/node_modules/appium/node_modules/appium-xcuitest-driver/WebDriverAgent/Carthage/Checkouts/CocoaAsyncSocket/CocoaAsyncSocket.xcodeproj CODE_SIGNING_REQUIRED=NO CODE_SIGN_IDENTITY= CARTHAGE=YES -list) failed with exit code 72:
xcrun: error: unable to find utility "xcodebuild", not a developer tool or in PATH

解决方法:选择Command Line Tools
4B5E5CEB2F36F92645AADA93F61EADCE.png

Xcode -> Preferences -> Locations -> Command Line Tools

3、长时间测试,server中断,这个无法解决,appium自身问题
4、webdriveragent启动失败,status、inspector无法正常查看,查看版本
5、appium脚本启动失败,查看脚本中的配置

阅读 3.1k

推荐阅读