安装指定版本(老版本)的PrimeNG

葬天尘

由于兼容问题,有时候还是要安装老版本的PrimeNG的,ng-zorro-antd也可以参照本方法

  1. 卸载已有版本:npm uninstall primeng --save
  2. 清理缓存:npm cache verify
  3. 安装老版本:npm install [email protected] --save,其中的x.x.x是版本号
    截止2019年1月22日PrimeNG7.0.4,前一个稳定的大版本号是6.1.7

安装兼容版本的PrimeNG同时可以解决:

node_modules/primeng/components/table/table.d.ts(15,86)

诸如此类的错误提示,缺少括号或者分号的错误,都是版本兼容问题

阅读 2.4k
267 声望
7 粉丝
0 条评论
267 声望
7 粉丝
文章目录
宣传栏