关于Django2.x安装mysql报错的一点建议

0

最近新建项目,想测一下Django的最新的版本,在集成Mysql的时候,安装pymysql,会遇到这个问题。(django.core.exceptions.ImporoperLyConfigured:mysqlclient1.3.13 or newer is required; you have 0.9.3)测试新版本的很多人都遇到这个问题。
出现问题的原因是 Django2.x之后不在支持python2了,而原来集成mysql的mysqlclient不支持python3。有一段时间,想用python3在Django中写代码,都是用了另一个包pymysql。它简单替换了mysqlclient。

import pymysql
pymysql.install_as_MySQLdb()

但是在Django2.2的时候对mysqlclient的版本做了校验,必须高于1.3.13,而pymysql版本是0.9.3。网上很多的方法都是说直接把Django校验版本的那两行代码注释掉就能跑。这种做法很蠢,特别的蠢。

首先,Django不会闲着无聊就加这个校验,一定有其他的原因。你注释掉现在能跑了,后面出了更麻烦的问题你怎么解决?在解决一个已知问题时,引入N个不确定的问题?其次,你如果要把项目产品化怎么办?每次更新后手动去改代码??你跑Docker跑runner怎么处理?最后,即便你是自己调试,也是有问题的。这是一个工程问题,如果你处理一个你解决不了的问题时,思路不是用成熟的方案绕过去,而是注释掉报错的地方,你觉得很geek?这不是掩耳盗铃?

至于为什么会校验,在github上有一个回答,https://github.com/PyMySQL/Py...

mysqlclient returns bytes object
PyMySQL returns str object

解决方案:1.将Django回退到支持pymysql的Django2.1.4版本。2.使用postgres或者其他数据库替代mysql

你可能感兴趣的

载入中...