1064Complete Binary Search Tree(30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integerN(≤1000). ThenNdistinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
思路
- 使用数组构造完全二叉树。
- 一棵完全二叉树可以构造出唯一的一棵完全二叉查找树(CBST)。
- 二叉查找树(BST)的中序序列是递增序列,于是在完全二叉树的中序遍历中构造出中序序列的CBST。最后将CBT顺序输出即是CBST的层次遍历序列。
代码
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1010;
int n, number[maxn], cbt[maxn];
int index = 0;
void inOrder(int root)
{
if (root > n) return;
inOrder(root * 2);
cbt[root] = number[index ++];
inOrder(root * 2 + 1);
}
int main()
{
scanf("%d", &n);
for (int i = 0; i < n; i ++)
{
scanf("%d", &number[i]);
}
sort(number, number + n);
inOrder(1);
for (int i = 1; i <= n; i ++)
{
printf("%d", cbt[i]);
if (i < n)
printf(" ");
}
return 0;
}
**粗体** _斜体_ [链接](http://example.com) `代码` - 列表 > 引用
。你还可以使用@
来通知其他用户。