1099Build A Binary Search Tree(30分)
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integerN(≤100) which is the total number of nodes in the tree. The nextNlines each contains the left and the right children of a node in the formatleft_index right_index
, provided that the nodes are numbered from 0 toN−1, and 0 is always the root. If one child is missing, then−1will represent the NULL child pointer. FinallyNdistinct integer keys are given in the last line.
Output Specification:
For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42
Sample Output:
58 25 82 11 38 67 45 73 42
思路
- 对于一棵二叉树中序序列是递增的,因此将给定的序列从小到大排序,之后按照进行中序遍历,将排好序的序列插入到二叉排序树中,最后进行层次遍历即可。
代码
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 110;
int data[maxn];
int n;
struct node
{
int data;
int lchild, rchild;
}Node[maxn];
int num;
void in_create(int root)
{
if (root == -1)
return;
in_create(Node[root].lchild);
Node[root].data = data[num ++];
in_create(Node[root].rchild);
}
void layer_order(int root)
{
queue<int> q;
q.push(root);
int num = 0;
while (!q.empty())
{
int now = q.front();
q.pop();
num ++;
printf("%d", Node[now].data);
if (num < n)
{
printf(" ");
}
if (Node[now].lchild != -1) q.push(Node[now].lchild);
if (Node[now].rchild != -1) q.push(Node[now].rchild);
}
}
int main()
{
//freopen("test.txt","r", stdin);
scanf("%d", &n);
int lchild, rchild;
for (int i = 0; i < n; i ++)
{
scanf("%d %d", &lchild, &rchild);
Node[i].lchild = lchild;
Node[i].rchild = rchild;
}
for (int i = 0; i < n; i ++)
{
scanf("%d", &data[i]);
}
sort(data, data + n);
in_create(0);
layer_order(0);
return 0;
}
**粗体** _斜体_ [链接](http://example.com) `代码` - 列表 > 引用
。你还可以使用@
来通知其他用户。