本题要求实现函数输出n行数字金字塔。
函数接口定义:
void pyramid( int n );
其中n
是用户传入的参数,为[1, 9]的正整数。要求函数按照如样例所示的格式打印出n
行数字金字塔。注
意每个数字后面跟一个空格。
裁判测试程序样例:
#include <stdio.h>
void pyramid( int n );
int main()
{
int n;
scanf("%d", &n);
pyramid(n);
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例:
5
输出样例:
1
2 2
3 3 3
4 4 4 4
5 5 5 5 5
#include <stdio.h>
void pyramid( int n );
int main(void)
{
int n;
scanf("%d", &n);
pyramid(n);
return 0;
}
void pyramid( int n )
{
int i, t;//t表示空格的数
for(i=1;i<=n;i++)
{
for(t=1;t<=n-i;t++)
{
printf(" ");
}
for(t=1;t<=i;t++)
{
printf("%d", i);
printf(" ");
}
putchar('\n');
}
}
**粗体** _斜体_ [链接](http://example.com) `代码` - 列表 > 引用
。你还可以使用@
来通知其他用户。