升级Xcode12 遇到的问题

一纶新岳

错误一

ReactNative报'event2/event-config.h' file not found解决方案

打开testApp.xcworkspace编译出现'event2/event-config.h' file not found
image.png

查阅是因为Flipper-Folly版本导致的,将iOS文件下的 Podfile 文件做如下修改

use_flipper! 修改为 use_flipper!({ 'Flipper-Folly' => '2.3.0' })

改完后保存,将Podfile.lock文件删除,然后重新 pod install
installed完成后,返回上层目录执行 yarn ios (或react-native run-ios)就可以启动了
解决方案来自:
https://github.com/facebook/r...

错误二

[!] Unable to find a specification for `Bugly (= 2.5.9)` You have either: * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`. * mistyped the name or version. * not added the source repo that hosts the Podspec to your Podfile.

在podfile中添加

source 'https://github.com/CocoaPods/Specs.git'

错误三

xcode12 pod集成友盟报错 "_OBJC_CLASS_$_UMSLEnvelopeBuild", referenced from

报错信息

Undefined symbols for architecture arm64:
  "_OBJC_CLASS_$_UMSLEnvelopeBuild", referenced from:
      objc-class-ref in UMShare(UMCommonStatisticsManager.o)
ld: symbol(s) not found for architecture arm64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

问题背景
公司要做第三方分享登陆,首先就想到友盟,于是按友盟官方的方法,在Podfile里写入

  pod 'UMCCommon' # 友盟基础库
  pod 'UMCShare/UI' # 友盟分享UI
  pod 'UMCShare/Social/WeChat' # 微信

结果发现报错,错误信息在下边。
经过种种搜索无果。回去看文档的时候突然发现友盟的库在2020.10.14更新了一版7.2.2版本。
UMSLEnvelopeBuild是基础库里的东西,抱着试一试的态度,我将基础库降低了一版,解决。在此记录一下分享给大家。猜测可能是没用xcode12做pod测试?🤔

如何解决
将友盟基础库降低一版即可,我使用的是7.1.3版本,将Podfile里友盟的基础库指定成7.1.3即可

  pod 'UMCCommon', '~> 7.1.3' # 友盟基础库
  pod 'UMCShare/UI', '~> 6.9.10' # 友盟分享UI
  pod 'UMCShare/Social/WeChat' # 微信
阅读 3k

一纶新岳
个人专栏
54 声望
3 粉丝
0 条评论
54 声望
3 粉丝
文章目录
宣传栏