Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
Sample Input
1

10 1
20 3
30 4
0 0
Sample Output
Case 1: 2
Case 2: 4
Case 3: 5

#include <algorithm>
#include <iostream>
using namespace std;
const int maxn = 1005;
#include <vector>
#include <stack>
#include <queue>
#include <cmath>
#include <string>

int main() {
    int total = 0;
    scanf("%d",&total);
    while(total--){
        int n,m,Case = 0;
        while(scanf("%d %d",&n,&m) != EOF){
            if(n == 0 && m == 0){
                break;
            }
            Case ++;
            int ans = 0;
            for(int i = 1; i < n; i++){
                for(int j = i + 1; j < n; j++){
                    if((i * i + j * j + m)%(i * j) == 0){
                        ans ++;
                    }
                }
            }
            printf("Case %d: %d\n",Case,ans);
        }
        if(total){
            printf("\n");//此处需特别注意,当t未自减到0时,0 0  break只是将内while断掉,继续执行while(t--)
            //此时需要换行继续开始执行while(scanf("%d %d",&n,&m) != EOF) ,直至输入第t组0 0 才外while循环结束
            //因为此时t已经到0,while(0)自动终止 
        }
    }
    return 0;
}


沐小轲
9 声望0 粉丝

C++初学者