安装 Druid 安装的时候提示 JAVA 版本的问题

HoneyMoose

错误信息如下

yhu@YuCheng-Hu:~/apache-druid-0.21.1/bin$ ./start-nano-quickstart
Druid only officially supports Java 8. Any Java version later than 8 is still experimental. Your current version is: 11.0.11.

If you believe this check is in error or you still want to proceed with Java version other than 8,
you can skip this check using an environment variable:

export DRUID_SKIP_JAVA_CHECK=1

Otherwise, install Java 8 and try again.

This script searches for Java 8 in 3 locations in the following
order

  • DRUID_JAVA_HOME
  • JAVA_HOME
  • java (installed on PATH)

问题和解决

这个其实不是问题,出现上面提示的原因就是 Druid 在安装的时候需要校验 Java 的版本。

因为 Druid 是在 Java 8 上编译的,虽然 11 的版本也能够运行。但是会提示上面的错误。

如果你是运行 JDK 11 的版本的话,请运行命令:

export DRUID_SKIP_JAVA_CHECK=1

然后再次尝试运行就可以了。

https://www.ossez.com/t/druid...

阅读 145
0 声望
0 粉丝
0 条评论
你知道吗?

0 声望
0 粉丝
宣传栏