安装UltiSnips笔记

gaoliming

问题 mac vim 不支持python3

环境: Catalina 10.15.6、iterm、zsh

UltiSnips插件需要vim支持python3,原文描述如下:

This plugin works with Vim version 8.0 or later with Python 3 support enabled.
It only works if the 'compatible' setting is not set.

The Python 3.x interface must be available. In other words, Vim
must be compiled with the |+python3| feature.
The following commands show how to test if you have python compiled in Vim.
They print '1' if the python version is compiled in, '0' if not.

Test if Vim is compiled with python version 3.x: >
    :echo has("python3")

如是使用mac系统的vim是不支持python3的,具体解决办法网上很多,但是我按照网上的解决办法重新安装vim之后输入命令:

which vim

总是得到如下结果:

/usr/bin

而且我的/etc/paths中的内容已经修改为

/usr/local/bin
/usr/bin
/bin
/usr/sbin
/sbin

所以vim依旧不支持python3。

如果你也遇到同样的情况,一定要记得重启iterm

文章:
自定义代码片段

阅读 379

出租车司机

82 声望
1 粉丝
0 条评论

出租车司机

82 声望
1 粉丝
文章目录
宣传栏