直接看package.json的配置

{
  "devDependencies": {
    "vue-server-renderer": "^2.6.14",
    "vue-template-compiler": "^2.6.14",
    "vuepress": "^1.9.9"
  },
  "dependencies": {
    "vue": "^2.6.14"
  }
}

vuepress指定vue版本的原因,我需要用vuepress来编写UI组件库文档,但我的vue版本是锁定在2.6.14,所以导致默认安装vueprees时候,vue-server-renderervue-server-renderer这2个包与vue不统一报错(vuepress@1.x默认安装最新版本应该是2.7)。所以需要指定安装这2个包的版本。

npm i -D vue-server-renderer  vue-template-compiler

vuepress中使用UI库

.vuepress/enhanceApp.js

import Element from 'element-ui';
import 'element-ui/lib/theme-chalk/index.css';

export default ({ Vue, options, router }) => {
  Vue.use(Element);
};

看见了
840 声望13 粉丝

前端开发,略懂后台;