解决 Android Gradle 依赖的各种版本问题

2018-07-29
阅读 7 分钟
26.4k
相信大家在build.gradle中引入各种依赖的时候,或多或少会见过一些红线,gradle会提示你,当前的编译版本和你依赖的这个支持库的版本号不同,应该使用相同的支持库版本,来比避免编译不通过问题,类似于这种。

面试题 之 『 Activity启动模式 』

2017-11-01
阅读 3 分钟
3.1k
终于撇开恶心的业务代码,有时间来复习下android知识了,笔者也属于那种,间歇性雄心斗志,持续性混吃等死,的人,每天加班干到深夜,都 ™ 没时间学习,复习一些知识了,本篇文章也是一种记录,一种备忘,要是一不小心帮助到了别人,想必也是极好的,笔者知识有限,也在学习,难免纰漏,万望海涵,请指正,行,废话就到...

利用Telerik Fiddler 进行手机抓包!

2017-04-17
阅读 3 分钟
9.7k
分享一下一款强大的抓包工具,希望对大家日常工作中有帮助! 一、Telerik Fiddler 软件安装: 大家可以在BaiDu,Google,或者他的官网下载他最新的版本进行安装! 二、Telerik Fiddler 配置: 安装完毕,打开软件进行相关配置。 1. 开启抓包:File---Catture Traffic 选上 同时左下角显示 Capturing 2. 开启Https的过滤:...

DataBinding 的Listview绑定

2017-02-04
阅读 6 分钟
7.5k
现在的时间是: 2017-2-4 10:35:07 使用的工具版本分别是: AndroidStudio 2.2.3 gradle 2.2.3

Android 4.0低功耗蓝牙开发!

2017-01-03
阅读 6 分钟
4.8k
    公司开发任务是,将医疗设备通过蓝牙集成到app中,在这开发中遇到了数不尽的坑.在此记录一下做一个记录,如果其他开发人员看见或许能提供一些帮助,如有不对,尽情指正,不胜感激!   刚开始接触的时候,被各种超长的API吓到了,像:BluetoothGatt , BluetoothGattCharacteristic , BluetoothGattDescriptor 等等.而且还要做多...