YouCompleteMe unavailable : requires Vim 7.4.143

1

版本问题

ubuntu 14.05 安装完YouCompleteMe后不生效,提示:YouCompleteMe unavailable : requires Vim 7.4.143
经过检索与查询,ubuntu自带的vim为7.4.50,需要安装最新的vim。
在stackoverflow上查到更新方案如下:

sudo add-apt-repository ppa:jonathonf/vim 
sudo apt update 
sudo apt install vim 

sudo add-apt-repository ppa:jonathonf/vim
sudo apt-get update && sudo apt-get upgrade

结果,还是不行,ubuntu提示:”The following packages have been kept back”,其中列出了vim的相关组件,但没有进行安装。
经检索找到问题的解释是:因为有部份packages的安装版比release版新。
进行如下操作:apt-get -u dist-upgrade(强制更新软件包到最新版本,并自动解决缺少的依赖包) ,问题解决。

python问题

还会遇到提示缺少python支持,但发现系统中已经安装了其所要求的python版本。经搜索,原因应该是所安装的vim版本不支持python,但我并不想用源码安装,最后找到一个方案,运行如下命令:

sudo apt-get install vim-nox

这样,你就可以在vim --version | grep python中看到,vim已经支持python3了,问题解决。

阿里云镜像问题

在阿里云的ubuntu14.04中add-apt-repository命令找不到,需要安装以下依赖包:

apt-get install python-software-properties software-properties-common -y

如果觉得我的文章对你有用,请随意赞赏

你可能感兴趣的

载入中...