安装Scrapy库报错 “error: Microsoft Visual C++ 14.0 is required. ”解决方法

Judenpech

问题描述

当前环境win10,python_3.6.5,64位。

Python 3.6.5 (v3.6.5:f59c0932b4, Mar 28 2018, 17:00:18) [MSC v.1900 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.

在windows下,在dos中运行pip install Scrapy报错:

error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudi...

解决方案

我的为Twisted-18.4.0-cp36-cp36m-win_amd64.whl
注意:cp后面是python版本,amd64代表64位

  • 运行命令:pip install D:\Download\Twisted-18.4.0-cp36-cp36m-win_amd64.whl

注意输入下载的Twisted的正确路径。

  • 安装完成后,再次运行:pip install Scrapy
  • 即可安装成功。
阅读 24.1k
100 声望
2 粉丝
0 条评论
100 声望
2 粉丝
文章目录
宣传栏