集成第三方框架出现错误java.lang.NoSuchFieldError: LOGGER怎么解决?

如上集成第三方框架出现错误java.lang.NoSuchFieldError: LOGGER怎么解决?

回复
阅读 7.2k
1 个回答

这个很明显是版本冲突导致的。
你可以尝试这样解决:

  1. 找到异常类所存在的jar
  2. 查看项目中的依赖关系, mvn dependency:tree
  3. 从dependency:tree 中找到依赖关系和依赖版本
  4. 手工升级或降级冲突jar(这个需要反复尝试)

但如果你正在使用spring-boot,同时第三方框架已经被spring-boot集成,可以尝试去掉自定义版本,使用spring-boot-parent中定义的版本即可

宣传栏