@vue/composition-api这个组件一定要ts4.2以上吗?

MrChenXP
  • 1
广东新手上路,请多包涵

已解决:使用1.1.3版本。
项目上有使用vue-property-decorator这个组件,涉及140个页面,但升级到ts4.0以后各种报错。所以不想升级4.0.
但@vue/composition-api又说要4.2以上。
该怎么办?升4.0那vue-property-decorator不能用,不升,那@vue/composition-api又不能用。
以下是vue-property-decorator+ts4.0的报错情况
image.png
以下是@vue/composition-api+ts3.0的报错情况
image.png

回复
阅读 378
1 个回答

vue-property-decorator 应该是依赖 老版本的 decorator实现,tsconfig 中可以设置回去,

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏