mac下安装express失败

提示是这个样子的

chenshengtekiMacBook-Pro:~ cs$ npm install express
express@4.3.2 node_modules/express
├── parseurl@1.0.1
├── utils-merge@1.0.0
├── merge-descriptors@0.0.2
├── cookie@0.1.2
├── escape-html@1.0.1
├── debug@0.8.1
├── cookie-signature@1.0.3
├── range-parser@1.0.0
├── fresh@0.2.2
├── qs@0.6.6
├── methods@1.0.0
├── buffer-crc32@0.2.1
├── serve-static@1.1.0
├── path-to-regexp@0.1.2
├── proxy-addr@1.0.0 (ipaddr.js@0.1.2)
├── type-is@1.2.0 (mime@1.2.11)
├── send@0.3.0 (debug@0.8.0, mime@1.2.11)
└── accepts@1.0.1 (negotiator@0.4.3, mime@1.2.11)
chenshengtekiMacBook-Pro:~ cs$ express -v
-bash: express: command not found

反正就是找不到,应该是没成功,之前也安装过几次,各种报错,就是安装不成功,求解

回复
阅读 9.1k
6 个回答

node.js包管理默认安装当前目录下的node_modules,你需要加-g参数,指定全局安装

好吧,一个月前的问题,现在才来回答一下,主要是自学,断断续续中间又耽搁了,今天看了各位的答案发现还是不行,又找了其他的办法,发现这条命令成功了,思路与我所采纳的答案是一个意思,但是貌似先清除一遍

sudo npm install -g express-generator

就是这个样子,多谢各位帮忙哈,已经行了

chenshengtekiMacBook-Pro:~ cs$ express -V
4.2.0
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏