每次更新 Xcode,所有插件都不能用了 =_=

fal_con
  • 83

Xcode 每次更新有个很头疼的问题,就是插件都会失效,要重装。
不得不说好多插件还是非常方便能提高效率。

还有就是 Xcode 更新插件不适配的问题

回复
阅读 15.4k
4 个回答

一句命令修复Xcode6.2插件失效的问题,不用谢我,我是雷锋
find ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins -name Info.plist -maxdepth 3 | xargs -I{} defaults write {} DVTPlugInCompatibilityUUIDs -array-add A16FF353-8441-459E-A50C-B071F53F51B7

一楼的答案其实是能用的,但是他取的是固定的uuid。给你一个根据当前开发环境的。
find ~/Library/Application\ Support/Developer/Shared/Xcode/Plug-ins -name Info.plist -maxdepth 3 | xargs -I{} defaults write {} DVTPlugInCompatibilityUUIDs -array-add defaults read /Applications/Xcode.app/Contents/Info.plist DVTPlugInCompatibilityUUID

LFL
  • 1
新手上路,请多包涵
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏