Sprity安装不成功

rayliao
  • 3.1k

好像是里面模块sprity-lwip安装不了的问题。

npm install sprity

图片描述

图片描述

单独安装sprity-lwip也不行。

npm installl sprity-lwip

图片描述


sprity需要安装sprity-lwip,而sprity-lwip又需要安装模块lwip,lwip需要node-gyp预编译才可以。

最后我尝试安装lwip,也不成功,快吐血了。

Installation of this module involves compiling native code. If npm
install lwip failes, you probably need to setup your system. See
instructions
. Building on Windows with Visual Studio requires
version 2013 or higher.

上面这句是lwip的安装介绍,如果安装失败的话,可能需要设置下系统,可我根据他说的,安装了必须的,还是不行。

回复
阅读 4.2k
3 个回答
✓ 已被采纳

windows环境就是大坑,lwip很难安装成功,不过最近我把系统升级到win10之后,sprity就可以安装成功了。

可以试下用以下3种方法
1.通过config命令

npm config set registry https://registry.npm.taobao.org 
npm info underscore (如果上面配置正确这个命令会有字符串response)

2.命令行指定

npm --registry https://registry.npm.taobao.org info underscore 

3.编辑 ~/.npmrc 加入下面内容

registry = https://registry.npm.taobao.org

折腾这个一天!!!差点重装系统
以前能用半年没切图了,中途更新过node版本,昨天发现就安装报错,各种纠结...
然后将node版本降级到4.70终于成功了!
安装报错的用户可以试下,仅供参考。(希望也能解决你们的问题)

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏