apache里面的mod_authz_default.so不存在怎么解决

太平长安灯
  • 201

在unbuntu执行php5.3升级到5.5后,apache出现错误

Output of config test was:
apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/authz_default.load: Cannot load /usr/lib/apache2/modules/mod_authz_default.so into server: /usr/lib/apache2/modules/mod_authz_default.so: cannot open shared object file: No such file or directory
Action 'configtest' failed.
The Apache error log may have more information.

回复
阅读 4.3k
1 个回答

这和PHP无关,就是apache 2.4中,这个模块被移除了,如果你不需要的话,可以配置文件里面删除对应的行
包括这三个模块mod_authz_default, mod_authn_default, mod_mem_cache

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏