mac 编译安装php7 报错

coachmans
  • 4.6k

执行sudo make报错信息如下

图片描述

回复
阅读 4.1k
4 个回答

openssl 的库出现的问题,因为 openssl 的头和实际库不匹配出现了问题,mac 上编译 php 问题多多,坑到处都是。特别是新版 OSX 还加入了核心保护,sudo 都不能重新编译和替换内置的 openssl 等 php 所依赖的库。我这几天也在弄 mac 上编译 php 的事,只能说给你两个建议,这两个算是最简单的了。

一、如果你是测试环境,调试 php 的功能,不需要 openssl 等扩展的支持,可以编译配置时直接关掉相应的支持,只编译纯纯的 php。

二、如果你是开发、生产环境,需要 php 的扩展都存在,可以直接用 homebrew 安装 php , homebrew 中已经含有最新到 7.0.1 的 php 版本了,可以满足对新版的需要。

cfanbo
  • 658

没办法解决,也遇到这个问题,我知道的算上你已经三个人遇到这个问题了。最后只好brew安装了

图片描述

我是用phpbrew来编译和管理php的,无论是需要多个不同版本的PHP,需要管理扩展的开关等等都很爽

http://phpbrew.github.io/phpbrew/

phpbrew install php-7.0.0 +default +mysql +sqlite +pgsql +fpm +tokenizer +opcache +iconv

关于openssl,首先brew install openssl,然后(如果有的话)注意移除(改名)xcode中的openssl库即可
其它依赖有缺基本就用homebrew装即可,GD库要带freetype的话好像需要手动指定一下

phpbrew ext install gd -- --with-freetype-dir=(brew --prefix freetype)

楼上正解
去掉 --with-opensll,是不是这样写啊 反正就是去掉opennssl这个编译参数

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏