spark on yarn运行应用出错!

wxmimperio
  • 720

在向yarn提交spark应用的时候出现如下错误:

clipboard.png

版本:
hadoop 2.7.1
spark-1.5.2-bin-hadoop2.6

是什么原因,求大神解答!

回复
阅读 3.7k
1 个回答

简单说就是版本不匹配,主要检查下工程pom里面的相关组件的版本。还有下载时选择的hadoop版本(虽然从你给的信息来看应该没问题)

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏