MAC os X 10.11.5中把python2.7升级到3.5后idle无法打开

zthanatos
  • 8

今天把MAC os 10.11.5中python2.7升级到3.5后,python在控制端可以正常运行,但是idle无法打开了,请教各位大大这个情况要如何解决,谢谢!!

回复
阅读 4.5k
5 个回答

python2和python3自己都有一套IDLE,如果你使用python2升级到python3,使用python2自带的IDLE是无法正常工作的。

估计是有些库依赖2的运行不了了吧,解决方法是降级,没法降级就重装吧
系统的python最好别改,要用另外版本的可以用virtalenv

嗯,我原来也是和你一样。把Mac自带的Python2.7升级了,不光是IDLE无法正常打开运行,我编译安装其他的配置环境需要的软件都无法正常编译安装。最后又重新把低版本的2.7重新安装了才可以的。我建议你重新把2.7装回去

idle不会跟着升级,下个3的就行了,但是为什么要升级呢?直接下个python3.5不就得了,有些库是依赖于python2的,linux下一般都是自带两个版本

这个貌似不能升级。因为xcode等都依赖2.7这个版本,升级后就不能用了

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
你知道吗?

宣传栏