npm install 报错,不知道哪里出问题

缓缓
  • 1.3k

npm ERR! Windows_NT 6.1.7601
npm ERR! argv "E:\Program Files\nodejs\node.exe" "E:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js" "install"
npm ERR! node v4.4.1
npm ERR! npm v2.14.20
npm ERR! code EPEERINVALID

npm ERR! peerinvalid The package eslint-plugin-promise@2.0.1 does not satisfy its siblings' peerDependencies requirements!
npm ERR! peerinvalid Peer eslint-config-standard@6.2.1 wants eslint-plugin-promise@>=3.3.0

npm ERR! Please include the following file with any support request:
npm ERR! E:MySoftwaretestGitwebpackvue-projectnpm-debug.log

回复
阅读 3.2k
2 个回答

node版本低的问题,安装node 6.x版本应该可以了

人家让你装eslint-plugin-promise大于3.3.0的版本,你装的是个2.0.1。然后就痛苦了

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏