gulp+angularjs2 使用primeNG前端组件 编译报错 如何解决?

莫名欢喜
  • 1
新手上路,请多包涵

到primeNG官网http://www.primefaces.org/pri... 提供两种方法 一个是systemjs 一个是Webpack
目前我们工程已经用gulp了。

1、npm install primeng --save
之后我就开始引用 结果一编译的时候就报错:

clipboard.png

我上下载的组件包里看 是primeNG的typescript代码有用到readonly这个属性,这个属性是typescrit 2.0以上版本才支持,我又确认了下自己用的版本都是2.0以上 ,但是就是报这个错误。

tsconfig文件:

clipboard.png

回复
阅读 2.2k
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进