webpack 插件UglifyJsPlugin看文档时感觉有矛盾?

fcxh
  • 434

1.首先,官网“指南”里说UglifyJsPlugin是自带的插件,直接用就行
图片描述

2.然后在,插件介绍页面里,又说UglifyJsPlugin需要安装插件才能用,而且还要

const UglifyJSPlugin = require('uglifyjs-webpack-plugin');

声明这句话require一下,,但是这不与第一点这不矛盾吗?

图片描述


所以:我就试了试,发现,不用安装,不用声明require,直接用也是可以

然后,我就有点懵了...

回复
阅读 3.1k
2 个回答

webpack.optimize.UglifyJsPlugin是webpack的核心插件,是自带的,直接使用。

webpack.optimize.UglifyJsPluginuglifyjs-webpack-plugin是同一个插件,
你的第二张图片内容第一段就提到了,而且用途也说了,你可以安装指定的UglifyJS版本,而不使用webpack自带的,就这点区别。

当前是:4.30.0 版本

webpack.optimize.UglifyJsPlugin已经被移除了。

提示:
webpack.optimize.UglifyJsPlugin has been removed, please use config.optimization.minimize instead

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏