loader option has been deprecated - replace with "use"

fcxh
  • 434

如题:

loader option has been deprecated - replace with "use"

字面意思好像是 loader这个选项不被推荐,应用“use”代替

可是我的写法都是照着官方例子来写的,不应该出现这个吧!
图片描述

回复
阅读 2.8k
3 个回答
✓ 已被采纳

这个是 webpack 从 1 升级到 2 时的变动。

这是报错么?怎么看着像是警告,另外是哪里的loader要换成use?

后来试了下,vue-loader下面的options里面的loader换成use就没有警告了。嗯,这个改变的确是webpack1到webpack2的转变。

宣传栏