0

想安装geany编译器,但是遇到了依赖问题
代码如下

yl@yl-Rev-1-0:~$ sudo apt-get install geany

显示如下:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
您可能需要运行“apt-get -f install”来纠正下列错误:
下列软件包有未满足的依赖关系:
chromium-browser-l10n : 依赖: chromium-browser (>= 59.0.3071.109-0ubuntu0.16.04.1289) 但是 49.0.2623.108-0ubuntu1.1233 正要被安装
geany : 依赖: geany-common (= 1.27-1) 但是它将不会被安装
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。
另:尝试了使用

sudo apt-get -f install geany

但是依然不好用;
另:又尝试使用

sudo apt-get reinstall install XXX=XXX.1.2.3

依然不好用,我也知道是ubuntu常见的依赖修复问题,但是不知道如何解决。

撰写答案