mac系统下用python3安装django连接数据库pymysql报错的问题

_John
  • 454

clipboard.png

如图,在使用django连接mysql数据库的时候想安装mysqlclient但好像python3里面已经不支持了,然后就用了pymysql代替,但始终提示我mysqlclient 1.3.3 or newer is required; you have 0.7.11.None

回复
阅读 3.5k
4 个回答

这玩意报错说你的版本太低了

xncode
  • 26

mysqlclient现已支持py3

出现这个问题是你已安装了旧版本的mysqlclient,更新即可修复

如果想使用pymysql,需要在manage.py中增加:

try:
    import pymysql
    pymysql.install_as_MySQLdb()
except ImportError:
    pass

这里的提示说你的mysqlclient 版本太低了,需呀更新一下,如果使用pymysql 呀向楼上说的加上那些pymsql.install_as_MySQLdb()......

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏