cordova requirements 如何安装Android target和gradle?

see311
  • 384
PS D:\works\cordova_demo\demo> cordova requirements

Requirements check results for android:
Java JDK: installed 1.8.0
Android SDK: installed true
Android target: not installed
cmd: Command failed with exit code 1 Error output:
'avdmanager' �����ڲ����ⲿ���Ҳ���ǿ����еij���
���������ļ���
Gradle: not installed
Could not find an installed version of Gradle either in Android Studio,
or on your system to install the gradle wrapper. Please include gradle
in your path, or install Android Studio
Error: Some of requirements check failed

不懂Java,求问Cordova需求检查剩下两个Android target和gradle怎么装?
装了java jdk se和Android studio

回复
阅读 7.4k
6 个回答
✓ 已被采纳

用Android SDK manager,选择SDK platform装对应的api level
装android studio吧,装好配置好环境变量就行了

royluck
  • 3
新手上路,请多包涵

请问解决了吗?我也遇到这种问题:
Requirements check results for android:
Java JDK: installed 1.8.0
Android SDK: installed true
Android target: not installed
cmd: Command failed with exit code 1 Error output:
'avdmanager' �����ڲ����ⲿ���Ҳ���ǿ����еij���
���������ļ���
Gradle: installed C:Program Filesgradle-4.4bingradle
Error: Some of requirements check failed

404NotFound
  • 2
新手上路,请多包涵

请问你们是怎么解决这个问题的啊

我也是遇到这儿问题了, 不够我只有android target是uninstalled, 等待解决中....

南川
  • 1
新手上路,请多包涵

有人能帮忙解决一下吗

isee
  • 3
新手上路,请多包涵

把原来的项目删了,新建一个项目,添加平台的时候写cordova platform add android@6 --save就可以了(我是安装的cordova 6)

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
宣传栏