window.onload=function(){
var flag = true;
var img1 = document.getElementById("img1");
var img2 = document.getElementById("img2");
document.getElementById("sel").addEventListener('touchstart',function(){
if(flag){
img1.style.display='inline-block';
img2.style.display='none';
flag = false; // 为什么不能 !flag 这样写
}else{
img1.style.display='none';
img2.style.display='inline-block';
flag = true; // 为什么不能 !flag 这样写
}
})
}
=======
怎么把这段代码写到最精简呢
这段代码的意图是
toggle
显示状态,可以写成!flag
。原代码之所以没有这么写,我猜是因为两个img
的display
属性必须分开写,因此就都这么写了至于精简,这段代码的水分不算太大,如果换成我可能会写成这样
或者牺牲一点可读性,去掉三元表达式