python3 的 pip 更新问题

执行升级命令:

C:\Users\Sigma> python -m pip install --timeout 2000 -i https://pypi.tuna.tsinghua.edu.cn/simple/ --upgrade pip

出现提示:

Requirement already up-to-date: pip in d:\program files\python\python36\lib\site-packages
You are using pip version 9.0.1, however version 9.0.2 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.

但是检查版本并未更新:

C:\Users\Sigma>pip -V
pip 9.0.1 from d:\program files\python\python36\lib\site-packages (python 3.6)

请问如何是好?

阅读 4.8k
2 个回答

清华的源里面的是9.0.1pip默认检查更新的是官方源,去掉-i http://...就行

因为你用的是清华的源进行的pip的升级,而清华的源还没有更新到最新的pip 9.0.2

一般忽略这种提示就好,不是什么错误。当然你也可以直接upgrade进行升级。
pip升级

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
推荐问题
宣传栏