当 nvm 切换版本后 之前通过npm 全局安装的包以随之失效

naice
  • 2k

当 nvm 切换版本后 之前通过npm 全局安装的包以随之失效

cnpm什么鬼命令都不可以用了,

怎么解决呢??

回复
阅读 2.6k
1 个回答

举个例子你之前使用node v6.10.0并有相关全局包,现在想使用v8.10.0:
如果你用nvm install v8.10.0安装,v8是没有v6相关全局包的,可以使用 --reinstall-packages-from=<version>安装

nvm install v8.10.0 --reinstall-packages-from=v6.10.0
撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进
你知道吗?

宣传栏