composer require "spatie/laravel-backup:^3.0.0" 报错

彭涛
  • 197

1.composer require "spatie/laravel-backup:^3.0.0" 提示"./composer.lock" is not UTF-8, could not parse as JSON ,说明我的composer.lock不是utf8格式,不能解析里面的json数据,头一次安装遇到这种问题。
2.
clipboard.png
3.求大佬指点。

回复
阅读 1.6k
1 个回答

把 composer.lock 删除了试试重新执行试试, 或者用phpstorm一类的IDE将composer.lock 文件转为UTF-8 字符编码再试试

撰写回答
你尚未登录,登录后可以
  • 和开发者交流问题的细节
  • 关注并接收问题和回答的更新提醒
  • 参与内容的编辑和改进,让解决方法与时俱进