0

npm3以后,依赖从树装变成扁平

npm3以后有什么机制解决包版本冲突的问题吗?

  1. 先本地安装less-loader, less-loader依赖clone2.1.1。
  2. 再本地安装clone@2.0.0(指定版本2.0.0)。发现clone版本变成2.0.0

如果less-loader不兼容clone@2.0.0,那么打包的时候,不就报错了吗?

Josh 13
2018-07-12 提问
1 个回答
0

你看看此时node_modules/less-loader/node_modules目录下有没有惊喜。。。
建议去npm官网把v3的版本控制策略一文仔细阅读

撰写答案

你可能感兴趣的

推广链接